[mod_python] Lama, sorry: Windows, Apache 2.2.3, ModPy

Graham Dumpleton grahamd at dscpl.com.au
Mon Sep 18 18:01:36 EDT 2006

durumdara wrote ..
> Hi !
> Sorry for Lamaism.
> I used modpy in the years 2002-2003, but later I need to use Zope, so I
> forget many things in it.
> Then now I want to install it in WXP, with Py2.4.
> The first installation is not working, because when I start apache 2.2.3
> with httpd -x, it showed error message (some function(s) not found in 
> the library).
> The latest modpy versions are not working for me with Apache 2.2.3
> Next I trying to downgrade the version of modpy.
> The Apache is starting succf. with 3.2.10 version of modpy.
> But when I trying with the test.py, the source of the py showed, not the
> result of.

If Apache showed mod_python loading with no error and you got this,
it is possibly a misconfiguration on your part. I would suggest you might
step through the procedure outlined in:


> Next I tried with manually loading of mod_py. I started the interpreter,
> and tried to import something from modpy lib.
> And then I get error too: no module _apache.

That is normal.

> How to I get solution to this problem ?
> Every of the tests are showing Unix-based examples/solutions, but I need
> to working on XP.
> Sorry for bas english, I must write quickly... :-(

Write more slowly then. ;-)


More information about the Mod_python mailing list