[mod_python] Re: mod_python cannot find Python 2.4 --

J. Jeffrey Close jjeffreyclose at yahoo.com
Tue Jul 11 15:26:41 EDT 2006

Hi Ronald (and everybody) --

Hey hey, I fixed it.   

Ronald, thanks for the suggestions.  Unfortunately I had tried relinking various things in many different places, and none of them helped -- e.g. libraries in /usr/lib, and the main directory in /System/Library/Frameworks/Python.framework/Versions/2.3 -- to 2.4 --  and I think a few others too.  None of those helped.  

After playing awhile with hacking the makefile in mod_python/src/Makefile , I completely convinced myself that it was outside the scope of that project build where the problem was occurring.  I checked and found that it was being loaded through /Developer/SDKs/<...>/System/Library/Frameworks/Python.framework/Versions/2.3 .

I linked a  "2.4" from here to /Library/Frameworks/.../2.4 , and made Current->2.4 .  That worked.  

'otool -L mod_python.so'  now reports

        /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 88.1.3)
        /Library/Frameworks/Python.framework/Versions/2.4/Python (compatibility version 2.4.0, current version 2.4.0)

this is repeated in the Apache startup, which reports mod_python/3.2.8  Python/2.4.3

mod_python is happy and so am I    :)


----- Original Message ----
From: Ronald Oussoren <ronaldoussoren at mac.com>
To: J. Jeffrey Close <jjeffreyclose at yahoo.com>
Cc: mod_python at modpython.org
Sent: Monday, July 10, 2006 11:40:20 PM
Subject: Re: mod_python cannot find Python 2.4 --

On Jul 10, 2006, at 10:00 PM, J. Jeffrey Close wrote:

> Hi,
> This problem is fairly well-known, but I've tried all the  
> suggestions that I've seen online and none have helped.
> mod_python 3.2.8 from Source
> python 2.4.3
> apache 2.0.58
> It's the usual "new version of Python framework" problem.  I have  
> installed Python 2.4.3 with the Universal install that installs it  
> under /Library/Frameworks/Python.framework/Versions/{2.4,  
> Current} .  I built mod_python with
> ./configure --with-apxs=/usr/local/apache2/bin/apxs --with-python  
> <above path>/bin/python2.4
> When I run apache, the logs show
> "mod_python/3.2.8  Python/2.3.5 configured -- resuming normal  
> operation"
> I have tried with and without the configure options above.  I have  
> done 'otool -L mod_python.so' and it reports also 2.3.5.  No matter  
> what I've tried, otool/httpd refuse to see the new Python.   
> HOWEVER, when I build mod_python, everything reports python 2.4.3  
> in the configure and the build -- i.e. there is no indication that  
> it's not finding any of 2.4.

I've probably fixed this for python 2.5, and will backport this fix  
to 2.4.4 before that is released.  I did however add this  change for  
mod_python for Apache1 and don't know if the latest mod_python uses  
the same crude hack to locate the python library.

What happens if you do "ln -s ../../../Python /Library/Frameworks/ 
before you build mod_python?


More information about the Mod_python mailing list