[mod_python] mod_python thread error (probably my fault)

Oliver Nelson flxkid at techemail.com
Tue Oct 28 17:18:51 EST 2003


It worked great!  Thanx.  Now, why doesn't it work when I compile my own 2.3.2?  Is  the make install not overwriting somewhere where there is a 2.3 no threaded libpython?  How would I find out?  I'm just a curious kinda guy ;)


--- Mike Klein <mikeklein at sbcglobal.net> wrote:
You will get this same error trying to use SOAPpy too.

It means your Python that mod_python was built against doesn't support 
threads. You might have a thread.py module under your python libs dir 
but that doesn't mean your python supports threads.

Go the the mod_python page, get the appropriate version per your apache 
version, and then get EXACTLY the version of Python recommended. Build 
this python in your source tree (with threads!) and mod_python against 
this. Everything will work fine.


Oliver Nelson wrote:

>I'm trying to do some SOAP services with the ZSI stuff.  From a prompt my script reports no errors, but when I call the script from a browser (not expecting the SOAP to work through here, just testing for other errors) I get a mod_python error with a trace going back to threading.py about not being able to import module thread ("ImportError: No module named thread").
>Now, I got 2.3.2 through Apachetoolbox but that didn't work too well so I compiled and installed the newest apache and mod_python and python (no errors in this process).
>Other scripts not using scripting work fine.
>Any ideas?
>Mod_python mailing list
>Mod_python at modpython.org

More information about the Mod_python mailing list