[mod_python] 3.0.0 beta 4 - compile on Mac OS X

Laurence Tratt laurie at tratt.net
Tue Nov 12 11:51:18 EST 2002

On Tue, Nov 12, 2002 at 10:50:13PM +1100, Nathan Robertson wrote:

[Apache and MacOS X]
>>> make runs fine, make install breaks. Looked into it, and apxs doesn't
>>> create src/.libs/mod_python.so, only mod_python.lai (and the .la symlink
>>> to it). I tested this under Linux/PPC and Linux/i386 and both of them
>>> create the .so fine.
>>> Has anyone else tried a similar setup on Mac OS X? Any successes?
>> Exactly the same thing happens under OpenBSD - I presume that part of our
>> shared BSD heritage is causing us problems. Interestingly, mod_python
>> works (well, builds) under FreeBSD; I have no idea about NetBSD though.
> Yeah - I noted the FreeBSD note in the README, and did what it said, but
> that didn't make any difference.
> Interesting that you got that on OpenBSD though. Plain wierd actually.
> Is that OpenBSD/i386 or on another platform (ppc?).


> This could yet be an Apache bug in apxs, I guess. I haven't tried
> compiling any other modules against it.

I suspect it's either apxs (of which I know very little) or libtool (where
what I know I dislike). But that doesn't help me much as I am unable in a
short time scale to fix or coerce either of them :)

Best wishes,


More information about the Mod_python mailing list