[mod_python] LoadModule python_module libexec/mod_python.so causes apache failure to launch

Graham Dumpleton graham.dumpleton at gmail.com
Sat Aug 29 23:55:28 EDT 2009

2009/8/29 Philippe Antoniotti <pantoniotti at gmail.com>:
> Hi Graham,
> Thanks for the answer.
> I got mod_python source from modpython.org and I am on Leopard so the
> problem could be right there ;-)

If you mean tar ball, as I said that will not work, including not even
normally compiling and installing.

You need to check out source code from subversion repository and use it.

  svn co https://svn.apache.org/repos/asf/quetzalcoatl/mod_python/trunk

> I am using apache on MAMP and the "apache_error_log" in the MAMP/logs folder
> does not show any errors when the apache server refuses to start (I lauch it
> from the MAMP interface and it just does not start).

Did you run:

  /usr/sbin/apachectl -t

like I suggested?

This will cause any problems to show on stdout rather than being lost
in error logs or go missing altogether.

> 1- mod_python.so was not installed and I had to copy it manually as well as
> change permissions to -rw-rw-r-- (but I was not able the generate the @ all
> the other files have at the end : -rw-rw-r--@, how do you do that ? could
> not find it in the chmod definition)
> 2- Apache starts fine when I remove the line "LoadModule python_module
> modules/mod_python.so"

What do you need mod_python for? Have you consider using mod_wsgi if
only wanting to host a WSGI application?


> Thanks again
> Philippe
> On Thu, Aug 27, 2009 at 7:00 PM, Graham Dumpleton
> <graham.dumpleton at gmail.com> wrote:
>> 2009/8/28 Philippe Antoniotti <pantoniotti at gmail.com>:
>> > Hi there,
>> >
>> > I am installing mod_python on my Macbook OS X.
>> > ./configure and make install went well, but when I add "LoadModule
>> > python_module libexec/mod_python.so" in the Apache conf file, Apache
>> > refuses
>> > to start.
>> > I can't see any info in the log
>> > Also, it seems when reading the install log that mod_python.so was
>> > installed
>> > in usr/libexec/apache2/mod_python.so.
>> > I tried putting that line instead of the previous one but it still
>> > refuses
>> > to start.
>> >
>> > I tried the troubleshooting section but the  line "PythonHandler
>> > mod_python.testhandler" also makes apache fail to start
>> >
>> > Am I missing something ?
>> You don't say where you got mod_python source code from. The official
>> 3.3.1 tar balls will not work on Leopard.
>> You don't say what the actual error messages you get in Apache error
>> log or on startup are. Also use the -t option to apachectl to see if
>> of configuration test it generates any error message.
>> Graham

More information about the Mod_python mailing list