[mod_python] LoadModule python_module libexec/mod_python.so causes apache failure to launch

Graham Dumpleton graham.dumpleton at gmail.com
Thu Aug 27 19:00:17 EDT 2009

2009/8/28 Philippe Antoniotti <pantoniotti at gmail.com>:
> Hi there,
> I am installing mod_python on my Macbook OS X.
> ./configure and make install went well, but when I add "LoadModule
> python_module libexec/mod_python.so" in the Apache conf file, Apache refuses
> to start.
> I can't see any info in the log
> Also, it seems when reading the install log that mod_python.so was installed
> in usr/libexec/apache2/mod_python.so.
> I tried putting that line instead of the previous one but it still refuses
> to start.
> I tried the troubleshooting section but the  line "PythonHandler
> mod_python.testhandler" also makes apache fail to start
> Am I missing something ?

You don't say where you got mod_python source code from. The official
3.3.1 tar balls will not work on Leopard.

You don't say what the actual error messages you get in Apache error
log or on startup are. Also use the -t option to apachectl to see if
of configuration test it generates any error message.


More information about the Mod_python mailing list