[mod_python] on OSX Leopard: "The process has forked..." crash

Lawrence Wang levity at gmail.com
Mon Oct 6 18:51:26 EDT 2008

Hi! I compiled mod_python on OSX Leopard with a simple ./configure && make
&& sudo make install, and it works just fine for almost everything. However,
certain Python operations cause Apache to crash with many of these errors in
the log:

> The process has forked and you cannot use this CoreFoundation functionality
> safely. You MUST exec().
Break on
> to debug.

One example of code that causes this:

import urllib2
data = urllib2.urlopen('http://www.google.com').read()

I'm pretty sure this is caused by mod_python and not, say, python itself,
because I don't get the same error when I run the same script as a CGI
handler in apache.

The hardware is a MacBook with Core 2 Duo (hence 64-bit). Some googling
revealed that the same error is caused by an old PHP library[1], and that is
solvable by changing its configuration and recompiling, so I'm hoping the
same is the case here.

Any help you can offer is greatly appreciated!

Lawrence Wang

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mm_cfg_has_not_been_edited_to_set_host_domains/pipermail/mod_python/attachments/20081006/fb4aac4e/attachment.html

More information about the Mod_python mailing list