[mod_python] mod_python problem in Slackware

Jorey Bump list at joreybump.com
Wed Nov 26 10:21:05 EST 2008

Luis P. Mendes wrote, at 11/26/2008 09:58 AM:

>>> I'm trying to install mod_python in Slack 12.1, but have some
>>> difficulties.
>>> mod_python: 3.3.1
>>> apache: default (httpd-2.2.8), also tried with 2.2.9


> Thank you for your support, but the solution I found was in this blog.
> http://beerpla.net/2008/07/29/how-to-fix-symbol-lookup-error-usrsbinhttpd2-
> prefork-undefined-symbol-apr_ldap_ssl_init-2/
>  tried it and httpd works now.
> Just had to `ln -sf libaprutil-1.so.0.2.12 libaprutil-1.so.0`
> Apparently the link is the same as the old, but httpd now runs.
> It seems that the same problem happens in several distribuitions.

I haven't seen this error. Are you using the httpd 2.2.9 package that is
available as a security upgrade for Slackware 12.1? It works fine for me
(I upgraded from the originally supplied httpd 2.2.8 before installing

More information about the Mod_python mailing list