[mod_python] mod_python problem in Slackware

Luis P. Mendes luislupe at gmail.com
Wed Nov 26 09:58:13 EST 2008

2008/11/25 Graham Dumpleton <graham.dumpleton at gmail.com>:
> 2008/11/26 Luis P. Mendes <luislupe at gmail.com>:
>> Hi,
>> I'm trying to install mod_python in Slack 12.1, but have some
>> difficulties.
>> mod_python: 3.3.1
>> apache: default (httpd-2.2.8), also tried with 2.2.9
>> when configuring mod_python for installation: ./configure
>> --with-apxs=/usr/sbin/apxs or
>> ./configure --with-apxs=/usr/sbin/apxs --includedir=/usr/include/httpd/
>> it returns the error:
>> checking Apache version... /usr/sbin/httpd: symbol lookup error:
>> /usr/sbin/ httpd: undefined symbol: apr_ldap_ssl_init
>> this is equivalent to when I issue the comand: # /usr/sbin/httpd -v
>> /usr/sbin/httpd: symbol lookup error: /usr/sbin/httpd: undefined symbol:
>> apr_ldap_ssl_init
> If this doesn't work, especially when mod_python not even installed,
> then it is a problem with your Apache installation. Trying commenting
> out loading of mod_auth_ldap in Apache configuration.

Thank you for your support, but the solution I found was in this blog.
 tried it and httpd works now.

Just had to `ln -sf libaprutil-1.so.0.2.12 libaprutil-1.so.0`

Apparently the link is the same as the old, but httpd now runs.

It seems that the same problem happens in several distribuitions.


More information about the Mod_python mailing list