[mod_python] PSP returning empty result

Jim Gallacher jpg at jgassociates.ca
Sat Sep 29 13:20:11 EDT 2007

Nicholas Piël wrote:
> On Sep 28, 2007, at 8:50 PM, Nicholas Piël wrote:
>> Mod_Python: 3.3.1 (also tried 3.2.0)
>> Debian EDGE (stable and up2date)
>> Apache 2.2.3 (32bit, Prefork)
>> Python 2.5
>> Hi,
>> When trying to run some old code  which worked ok on mod_python 3.1 on 
>> a different server i bumped into a problem that got me stumped.
>> On this new server i am unable to render any PSP templates from within 
>> the Apache environment, however trying to parse the template from the 
>> prompt works fine (_psp.parse(filename)).
> *argh*
> The problem seems to be fixed when i disable PHP5. Is there anything 
> else i can do to fix this besides disabling PHP5?

Is there any indication in the apache error log that apache process is 
seg faulting? These sorts of problems can are often traced back to 
mismatches in library versions used by php, apache and python. The most 
common culprits are mysql and expat, but there are certainly others.

On the other hand I don't recall any specific instance where we've seen 
  library conflicts with psp.


More information about the Mod_python mailing list