[mod_python] sqlite commands in python 2.5.1 not working in modpython 3.3.1

Vikram Pudi vikram at iiit.ac.in
Sat Aug 4 05:58:37 EDT 2007

The problem is fixed!

I figured that the sqlite3.version gives the version of pysqlite and 
sqlite3.sqlite_vesion gives the sqlite's version... for me it was 3.4.0 
so that is quite recent.

I found this article at http://www.initd.org/tracker/pysqlite/ticket/174
which mentioned that the pysqlite that comes with python is 2.3.2 and it 
  doesnt work with modpython... so I downloaded the latest version of 
pysqlite and installed it and it worked!

The only problem is I need to do:
from pysqlite2 import dbapi2 as sqlite3

instead of plain: import sqlite3

But I'll live with that.


Vikram Pudi wrote:
> Since python 2.5.1 comes with sqlite inbuilt, I didn't compile sqlite 
> seperately. To find out the sqlite version, I did "import sqlite3" and 
> "print sqlite3.version". It outputs 2.3.2!  I am sure I have sqlite3.4.0 
> also installed on my system. How to fix this? To find out my os, uname 
> gives: "Linux cygnus 2.6.9-22.EL".
> Regards,
> -Vikram.
> Richard Lewis wrote:
>> On Saturday 04 August 2007 08:11:22 Vikram Pudi wrote:
>>> I have the latest versions of modpython (3.3.1) and python
>>> (2.5.1) compiled from scratch. I can create a connection and a
>>> cursor object, but cur.execute() commands dont work and the
>>> program doesnt proceed to the next line. There is no error
>>> output. Apache error log shows that the modpython child process
>>> exited with a segmentation fault.
>> What operating system are you using? What version of sqlite? Did you 
>> compile it and the Python bindings yourself too?
>> Have you tried just using pre-compiled binaries of Python / mod_python 
>> / sqlite instead?
>> Cheers,
>> Richard

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the Mod_python mailing list