[mod_python] Error: Cannot load mod_python module

Gutfreund, Yechezkal ygutfreund at draper.com
Mon Nov 6 11:22:17 EST 2006

I am a long-time (25+ years) distributed system (and OS) programmer, but
a newbie at mod_python and apache.
I believed I followed the install procedures. I added:
1. put the following line in httpd.conf
     LoadModule python_module modules/mod_python.so
2. created the /tmp director for the mutex's
3. added the <directory> section and put the mptest.py file in the test
    <Directory /some/directory/htdocs/test> 
        AddHandler mod_python .py
        PythonHandler mptest 
        PythonDebug On 
4. Installed ActiveState Python Version 2.4 python24.dll and mod_python
3.2.8 (and told it where Apache 2.2.3 (win) is located
5. All of this is on an XP Pro SP 2 machine
6. I still get the following ERROR:
The Apache service named reported the following error:

>>> httpd.exe: Syntax error on line 98 of C:/Program Files/Apache
Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/Program
Files/Apache Software Foundation/Apache2.2/modules/mod_python.so into
server: The specified procedure could not be found. .


I verified that the mod_python.so is indeed in this directory, and I
also tried moving python24.dll to the /bin directory of apache. But that
was the only relevant fixes I could see in the blogs, newsgroups, etc.


So I am posting here, to see if anyone has had similar problems.



Dr. Yechezkal Gutfreund
Draper Laboratory
555 Technology Square
Cambridge, MA 02139
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mm_cfg_has_not_been_edited_to_set_host_domains/pipermail/mod_python/attachments/20061106/5853e895/attachment.html

More information about the Mod_python mailing list