[mod_python] Mod_python on HP-UX 11.11

Buehre, Joseph R joseph.r.buehre at boeing.com
Fri Nov 3 08:02:00 EST 2006

 I tried linking as suggested to the .sl instead but to no avail.  I
will clean-up and start from scratch posting my results as I go through
the process....


This is a 32 bit compile and Apache was compiled with --enabled-so

Here is the compiler option in my script.

LDFLAGS=-L/opt/Boeing/python2.4.3/lib ./configure
--with-apxs=/wwimacs6/apache2/bin/apxs --with-python=/opt/Boeing/

Joe Buehre 
Mission Critical Systems Support 

 mailto:joseph.r.buehre at boeing.com

-----Original Message-----
From: Graham Dumpleton [mailto:grahamd at dscpl.com.au] 
Sent: Thursday, November 02, 2006 3:50 PM
To: Buehre, Joseph R
Cc: mod_python at modpython.org
Subject: Re: [mod_python] Mod_python on HP-UX 11.11

Buehre, Joseph R wrote ..
> To All-
> I have tried consently to get mod_python to compile and create the .so

> file for Apache.  To date this has been an unsucessful adventure.  Has

> anyone done this type of install with HP-UX 11.11, Apache 2.0 and the 
> latest version of mod_python.  Desperately seeking insight.

Presuming you are the same version who was asking about this in the past
couple of weeks, what was the outcome from when I suggested you change
the makefile to use -L/-l to link your shared Python library rather than
the .a? Without you giving feedback on what the outcome was of our
suggestions, including any error messages the compiler, or Apache may
have spat out, it is really hard to help and we just end up guessing.


More information about the Mod_python mailing list