[mod_python] Problem with configure

Graham Dumpleton grahamd at dscpl.com.au
Fri Apr 21 20:53:55 EDT 2006

Don't remove the parenthesis in configure. Find the one line of the

   MP_VERSION=`echo $MP_VERSION | sed s/\\"//g`

in "configure" and change it to:

   MP_VERSION=`echo $MP_VERSION | sed 's/["]//g'`

Much like you would have done in configure.in.

Note that configure is generated from configure.in only by developers
before release is made.


On 22/04/2006, at 10:05 AM, Sérgio Durigan Júnior wrote:

> Hi ;-)
> Well, I know it's a known problem, and I even found some answers
> (which didn't apply to my problem) in the internet. I'm running
> Slackware 10.2 here, with python 2.4 and Apache 2.0 installed, and I'm
> trying to install mod_python here for 2 hours without success... The
> error occurs when I'm running ./configure. The output is below:
> ---------------------
> neo at pegasus mod_python-3.2.8 $ ./configure
> checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> ...
> checking what libraries Python was linked with... -lpython2.4
> -lpthread -ldl  -lutil   -lm
> checking linker flags used to link Python...
> checking where Python include files are... -I/usr/include/python2.4
> ./configure: line 3427: syntax error near unexpected token `('
> ./configure: line 3427: `  as_lineno_3=`(expr $as_lineno_1 + 1) 2>/ 
> dev/null`'
> neo at pegasus mod_python-3.2.8 $
> ----------------------------------------------------------
> Ok, with this error in my hand, I took a look at Google, I found  
> this message:
> http://www.modpython.org/pipermail/mod_python/2006-February/ 
> 020468.html
> Its answer took me to:
> http://issues.apache.org/jira/browse/MODPYTHON-122
> I made the modifications listed in the link above (in my configure.in
> file), but it didn't work. So, I opened my configure file and removed
> the parenthesis which were causing the errors. After some time
> (because there were a lot of them to remove!), I tried again. Didn't
> work too. So, as I ran out of ideas, I decided to ask here :-)
> Ahh, by the way, I'm running bash 3.1.11(2)-release. Dunno if it
> helps, but anyway... ;-)
> Thanks!
> Sérgio.
> _______________________________________________
> Mod_python mailing list
> Mod_python at modpython.org
> http://mailman.modpython.org/mailman/listinfo/mod_python

More information about the Mod_python mailing list