[mod_python] mod_python interpreter creation issue

Graham Dumpleton grahamd at dscpl.com.au
Thu Mar 17 00:50:14 EST 2005

John Belmonte wrote ..
> Thanks for the reply.  I'm using mpm-worker.  I tried the mod_python 
> patch, but there was no change.  As far as third party packages, Quixote
> doesn't use threads as far as I know, and only has one C module.  ZODB
> has several C modules.  ZEO, which is on top of ZODB and where the 
> exception is happening, creates threads via the threading module.
> Do you have any suggestions as to what I should instrument to locate the
> problem?

Not really. You seem to know where the specific error comes from, so maybe
you can add debugging to understand the context in which it is being
executed and develop a very cut down example which demonstrates the
problem and which isn't dependent on any third party packages. If you can
do that and others can duplicate it then we might be able to help investigate.

I have already gone back and tried the original example which you cited:


However, I didn't have any problem running the example on my platform so
can't even use that as a basis for any investigation.

I also managed to fix yesterday the problem in the code I was talking about where
I personally was having issues with restricted mode, but overall I am still not
any further along in really understanding in general what causes Python to run
in restricted mode. Would need to do some more research about it when I have
the time.


More information about the Mod_python mailing list