[mod_python] Getting Advx to run with mod_python

Graham Dumpleton grahamd at dscpl.com.au
Sun Jun 12 19:40:35 EDT 2005

On 11/06/2005, at 12:49 AM, Kahlil Johnson wrote:

> I am using Mandrake 10.1 and it has Advx server wiht the Apache 2.0 .
> One thing that I found myself lost is locating the files for the
> apache configuration. I tried to put up the mod_python but all I get
> is that the mime-type is not recognize and the browser ask to download
> the .py.
> I wonder where can I get the AddType since the
> /etc/httpd/conf.d/httpd2.conf  dont includes the AddType in that file.
> Also I might ahve messed up somewhere else since it worked once but
> since I move several things I no longer know if it will again.

Using "AddType" in Apache to trigger mod_python isn't generally how
things are setup. You might want to review the installation 
for mod_python and start over with its test example. An alternate set
of instructions for getting a first test example in mod_python working
can be found at:


It describes some of the problems that can arise and where to look to
solve what is happening, including the common problem of why browsers
want to save the response to a file.


More information about the Mod_python mailing list