[mod_python] Mod_python quit working

Nicolas Lehuen nicolas.lehuen at gmail.com
Tue Jan 11 15:03:07 EST 2005

On Tue, 11 Jan 2005 12:40:32 -0700, Dan R. Olsen III
<python at dan-olsen.net> wrote:
> >>>
> >>>>I had a mod_python file that I was working on a few days ago. Now, when
> >>>>I type in the URL nothing happens. The browser just stays on the page it
> >>>>was already on. I haven't made any changes to the file or the system.
> >>>>I am using Fedora Core 2 with Apache 1.3 and mod_python 2.7. Any ideas?
> >>>It seems to be broken! Have you tried fixing it in any way? Restarting
> >>>apache? Echoing a simple string to the browser etc...
> >>Yes, I've restarted Apache and I have echoed a simple string and niether
> >>of those have worked.
> > Try getting the page with 'wget', see what headers you get back and if
> > there is any content.
> I get the following:
> --12:38:00--  http://dev.eclab.byu.edu/rose.py
>             => `rose.py'
> Resolving dev.eclab.byu.edu...
> Connecting to dev.eclab.byu.edu[]:80... connected.
> HTTP request sent, awaiting response...
> 12:38:00 ERROR -1: No data received.
> Why would it all of a sudden be receiving not data?

Do you have something in your error.log file ?

The file is normally in $APACHE/logs and it may contain interesting
informations about what's happening.

Is everything OK in your logging system ? Do you have enough free
space on the partition which contains the logs ?


More information about the Mod_python mailing list