[mod_python] compiling

Michael mogmios at mlug.missouri.edu
Wed Mar 3 23:24:12 EST 2004

Another problem that I ran into with the install process. I decided to 
move to keeping Apache and all webserving related programs to being 
contained within my webserver users files. Just to make it easier to 
make sure no extra files were interfering with the process. As a DSO the 
install process was having the same problem as before. I tried switching 
to a static compile and during install I got his error:

Performing static instalation.
/usr/bin/install -c -o webserve -g webserve -d 
/usr/bin/install: invalid user `webserve'
make[1]: *** [install_static] Error 1
make[1]: Leaving directory 
make: *** [install] Error 2

It looks to me as if the install script is cutting the last letter off 
my username.

> I'm recompiling Apache, Python, and mod_python to try to figure out 
> why mod_python + xmlrpclib doesn't work for me. I'm trying to use a 
> custom compled version of Python compiled without thread support to 
> see if that helps. I also compiled Apache without PHP this time.
> I noticed that during 'make install' I had problems because the script 
> was attempting to use an old copy of Python. I was surprised because 
> I'd told it where to find the copy of Python I'd custom compiled. 
> Maybe this is an installation bug? I had to manually kill the symlink 
> to the old copy of Python and point it to the new copy so that 
> installation could work properly.
> Now when I try to start Apache I get this error:
> Cannot load /usr/local/apache/libexec/mod_python.so into server: 
> /usr/local/apache/libexec/mod_python.so: undefined symbol: openpty
> /usr/local/apache/bin/apachectl start: httpd could not be started
> Any idea what's wrong? Thanks.

More information about the Mod_python mailing list