[mod_python] Re: Re: Mod_Python 2.7.8 and threading

Hr. Daniel Mikkelsen daniel at copyleft.no
Mon Jun 2 02:13:06 EST 2003

On Sun, 1 Jun 2003, Russell Yanofsky wrote:

> Hey, thanks for your help. I installed apache 2 and everything began to
> work! I still don't understand the behavior with apache 1.3. The fact that
> apache code is not threadsafe doesn't explain why threading.Thread.start()
> (which doesn't invoke any apache code) deadlocks. And AFAICT, there's only
> one version of python installed on my system and it does support threading.
> Oh well, hopefully apache 1.3 will go away soon.

Well, things are set up differently on different systems, I have experience
with OpenBSD and FreeBSD. If I tried to do what you did, I would have ended up
in one of two situations:

1) If I used a threaded Python for my mod_python, and attempted to load
mod_python in apache, I would get error messages about unresolved symbols
belonging to libpt. Since obviously, Apache isn't linked against that library.

2) If I used an unthreaded version, I would be able to load things and get
going, but I'd get undefined behaviour if I tried to use threading in my python
script, since the python binary doesn't support the calls the threading module
needs. This is probably what's happening to you.

-- Daniel

More information about the Mod_python mailing list