[mod_python] mod_python & apache config issues

George Lunsford glunsford at monbar.com
Wed Nov 6 14:22:42 EST 2002

For the past few days I've been experimenting with installing mod_python
2.7.8 on an Apache 1.3.22 server that was from the standard Caldera
OpenLinux 3.1.1 install.  First, I installed the Python interpreter v 2.1.3,
then I tried installing mod_python, and I ran into the whole threading
issue.  I recompiled Python 2.1.3 without threads, and put it in
/usr/local/web/.  I ran into the EAPI error, and added the OPT=-DEAPI into
the src/Makefile.  
Now whenever I run apache, if I do strace httpd -X, it looks like it's using
my threaded version of Python (in /usr/local/bin, there's a symlink in
/usr/bin/ to it).  I'll try and paste what I think are the relevant lines
stat64("/usr/local/sbin/python", 0xbfffe2ac) = -1 ENOENT (No such file or
stat64("/sbin/python", 0xbfffe2ac)      = -1 ENOENT (No such file or
stat64("/usr/sbin/python", 0xbfffe2ac)  = -1 ENOENT (No such file or
stat64("/bin/python", 0xbfffe2ac)       = -1 ENOENT (No such file or
stat64("/usr/bin/python", {st_mode=S_IFREG|0755, st_size=1469444, ...}) = 0
readlink("/usr/bin/python", "/usr/local/bin/python", 1024) = 21
readlink("/usr/local/bin/python", 0xbfffe434, 1024) = -1 EINVAL (Invalid
stat64("/usr/local/bin/Modules/Setup", 0xbfffe26c) = -1 ENOENT (No such file
or directory)
stat64("/usr/local/bin/lib/python2.1/os.py", 0xbfffe24c) = -1 ENOENT (No
such file or directory)
stat64("/usr/local/bin/lib/python2.1/os.pyc", 0xbfffe23c) = -1 ENOENT (No
such file or directory)
stat64("/usr/local/lib/python2.1/os.py", {st_mode=S_IFREG|0644,
st_size=17401, ...}) = 0
Apache would run, but at the first connection (even just to get the root
index file of a directory, it would segfault.  It doesn't appear to be doing
that anymore, however... now it exits with this error eventually (without
needing to connect to the server):
[Wed Nov  6 14:37:58 2002] [crit] (98)Address already in use: make_sock:
could not bind to port 80
I was wondering if anyone could give me any advice/help with this issue.
Thanks in advance.
George Lunsford
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.modpython.org/pipermail/mod_python/attachments/20021106/34dbf358/attachment-0003.htm

More information about the Mod_python mailing list