[mod_python] problem setting up mod_python under Ubuntu Breezy

Graham Dumpleton grahamd at dscpl.com.au
Fri Mar 3 05:00:33 EST 2006

On 03/03/2006, at 8:37 AM, Dan Lenski wrote:

> On 3/2/06, Graham Dumpleton <grahamd at dscpl.com.au> wrote:
>> If you are using all the default packages from the distribution,
>> including that for mod_python, it might be the case that the  
>> mod_python
>> package was originally compiled against an older version of Python  
>> and
>> thus will not work. Can you build the mod_python package yourself  
>> from
>> source code and use that instead?
> Thanks for the quick reply.  Your mod_python guide has been very  
> helpful to me.
> The package is called libapache-mod-python2.4, and it explicitly
> depends on python2.4.  When I run "strings mod_python.so", I come up
> with the string 2.4.1a0, whereas "python -V" gives me 2.4.2
> Could it be that this minor version difference is causing the
> conflict?  If so, I'll compile my own package ASAP.  Thanks,

Normally a minor sub revision change wouldn't cause a problem as
Python directories tend to only use major and minor version numbers
in directory names, eg. 2.4.

Anyway, if you don't mind compiling would definitely suggest that. I
would though strongly encourage you to upgrade to Apache 2.0 and
mod_python 3.2.8 in the process.


More information about the Mod_python mailing list