[mod_python] Which mod_python & apache versions

Graham Dumpleton grahamd at dscpl.com.au
Wed Jun 14 19:18:31 EDT 2006

On 15/06/2006, at 6:46 AM, Clemens Herschel wrote:

> I  have been unable to have apache load mod_python.so. I have tried  
> many
> version combinations.
> I am running Red Hat 9.0
> I am thinking of swithing to Debian-3.1 as package dependencies  
> seem to be
> taken care of.
> What version of mod_python works with what version of apache.
> I have enjoyed reading the mod_python mail and would like to get  
> started
> with modpython.
> Thanks for any suggestions
> Clemens Herschel

Might be easier if you tell us which version of Apache you want to  
use and
then we say which version of mod_python.

In general though:

   Apache 1.3 --> mod_python 2.7.11
   Apache 2.0 --> mod_python 3.2.8

You might be using at least Apache 2.0.47 (ish) though for mod_python  

You can't currently use Apache 2.2 unless you patch your code or use dev
version of mod_python 3.3 from subversion.

Also, you should post the specific problem/errors you are having.  
More often
than not it is configuration problems, especially if you have  
multiple versions
of Python installed.


More information about the Mod_python mailing list