[mod_python] remnant 'orphan' apache subprocesses

Graham Dumpleton graham.dumpleton at gmail.com
Tue Jan 22 22:00:08 EST 2008

On 23/01/2008, Alec Matusis <matusis at yahoo.com> wrote:
> > (gdb) thread apply all bt
> Thread 1 (Thread 1111562592 (LWP 3812)):
> #0  0x00002aaaab2c94df in sem_wait () from /lib64/tls/libpthread.so.0
> #1  0x00002aaaac204dcd in PyThread_acquire_lock (lock=0x5b7820, waitflag=1)

Hmmm, there should have been 39 other stack traces, one for each
worker thread based on your Apache configuration.

Don't necessarily post them all, but you should look and see what is
in frame #0 for all of them and see if there is anything odd such as
one blocking in a call out to some external C library. If no such
thing and they are all stuck on Python mutex locks, then must be
internal deadlock.

This still doesn't explain though how the process has been associated
with PPID of 1, which would  still only seem possible if something had
tried to daemonise process.



More information about the Mod_python mailing list