[mod_python] Trouble on OSX - Leopard again

Johannes Hoffart johannes at nudgenudge.eu
Fri Jan 4 04:10:37 EST 2008


I tried to install mod_python on osx and ran into the x86_64 trouble -  
I then followed the solution in this mailing list, which works nicely.  
There is one limitation, though, the _psp.so is still not x86_64:

file _psp.so
_psp.so: Mach-O universal binary with 2 architectures
_psp.so (for architecture i386):	Mach-O bundle i386
_psp.so (for architecture ppc7400):	Mach-O bundle ppc

The corresponding output in the make process shows that it is only  
compiled for those two archs, but I cannot find the right place in the  
Makefile to add x86_64. Apache loads fine, but throws this error upon  
accessing a .psp file:

ImportError: dlopen(/Library/Python/2.5/site-packages/mod_python/ 
_psp.so, 2): no suitable image found.  Did find:
	/Library/Python/2.5/site-packages/mod_python/_psp.so: no matching  
architecture in universal wrapper

I hope someone can point me in the right direction.
Thanks in advance!
Johannes Hoffart

More information about the Mod_python mailing list