[mod_python] Trouble on OSX - Leopard

Ben Mitchell ben at mitchellfamily.com
Mon Oct 29 13:16:11 EDT 2007

Hi, folks.

I'm working on getting Django running again after upgrading to  
Leopard.  I've hit a snag building / installing mod_python, and I'm  
hoping someone might know what's going on.

I did the following:
- downloaded the 3.3.1 source
- .config --with-apxs=/usr/sbin/apxs
- make
- sudo make install
- added to httpd.conf:  LoadModule python_module      libexec/apache2/ 

I then ran apachectl configtest and got an error:

% apachectl configtest
httpd: Syntax error on line 116 of /private/etc/apache2/httpd.conf:  
Cannot load /usr/libexec/apache2/mod_python.so into server: dlopen(/ 
usr/libexec/apache2/mod_python.so, 10): no suitable image found.  Did  
find:\n\t/usr/libexec/apache2/mod_python.so: no matching architecture  
in universal wrapper

Any ideas?  I've tried a bunch of things tracking this down, but I get  
this same error every time.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mm_cfg_has_not_been_edited_to_set_host_domains/pipermail/mod_python/attachments/20071029/ada10aa6/attachment.html

More information about the Mod_python mailing list