[mod_python] Apache directory listing

Aaron Gallagher habnabit at gmail.com
Wed May 30 03:27:51 EDT 2007

I just completely cleaned out my apache install, reinstalled it, and  
it seems to be working, but I'm having problems again, and I've heard  
of other people having the same problem. Every mod_python module I  
try to load will not load, and the error I get is that the modules  
can't be found.

I'm using a .pth file in my site-packages directory, and I can import  
the modules just fine from the interactive interpreter anywhere, and  
mod_python.testhandler is reporting that my module directory is in  

So, what's going on?

On May 29, 2007, at 10:49 PM, Aaron Gallagher wrote:

> Hah, wow, I guess that explains everything.
> I got really frustrated with all of my bizarre problems, so I tried  
> testing it on another machine.
> Everything worked _perfectly_. No problems whatsoever. Apache  
> autoindexed my directories and everything.
> The first thing I did was check the versions, and they're both  
> running apache 2.0.59 with mod_python 3.3.1. Weird.
> I'm going to do a complete reinstall of apache and see if that  
> fixes everything on the server. I hope so.

Aaron Gallagher
<habnabit at gmail.com>

More information about the Mod_python mailing list