[mod_python] Compiling mod_python on 64bit RHEL 4

Graham Dumpleton graham.dumpleton at gmail.com
Thu Mar 8 16:04:11 EST 2007

On 09/03/07, Posey, Jake E <Jake.E.Posey at boeing.com> wrote:
> I have a couple of issues.
> One is I have Apache 1.3.31 and Python 2.3.4 and I'm trying to compile
> mod_python 2.7.10 on 64bit RHEL 4 but after running configure
> –with-apxs=/ots/apache_1.3.31/bin/apxs the make dso fails
> with the following error.
> /usr/bin/ld: mod_python.o: relocation R_X86_64_32 against `a local symbol'
> can not be used when making a shared object; recompile with -fPIC
> mod_python.o: could not read symbols: Bad value
> collect2: ld returned 1 exit status
> apxs:Break: Command failed with rc=1
> make[1]: *** [mod_python.so] Error 1
> make[1]: Leaving directory `/tmp/mod_python-2.7.10/src'
> make: *** [do_dso] Error 2
> I've tried several version of  apache, python, and mod_python and I get the
> same error.

Have you tried a current version of Apache and mod_python and not some
really old versions? Ie., something like Apache 2.2.4 and mod_python

Trying to debug how to compile what is a very old version of
mod_python against a 64 bit platform isn't something that you will
probably find anyone willing to help with. By using a newer version
means we also know it isn't something that may have been resolved in a
newer version.


More information about the Mod_python mailing list