[mod_python] Mod_python on HP-UX 11.11

Deron Meranda deron.meranda at gmail.com
Wed Nov 15 14:49:35 EST 2006

On 11/15/06, Buehre, Joseph R <joseph.r.buehre at boeing.com> wrote:
> ltmain.sh (GNU libtool) 1.4.3 (1.922.2.110 2002/10/23 01:39:54)

That libtool is quite old, and old libtools on HP-UX are buggy sometimes.
If all else fails you may try replacing it with a newer version.  It's a bit
hackish, but when I've gotten stuck in the past (on other OSS programs)
with mysterious compiler/linker options it's sometimes worked for me.


You may also consider whether you want to go up to Apache 2.2
rather than 2.0.  (You must use the newest mod_python though).

> The -R is in the src/Makefile and is not in the Apache config_vars.mk
> file. I believe it is a compiler switch for the C compiler. Reference
> this link for -R http://docs.hp.com/en/B3901-90003/ch09s01.html

Can you show us the snippets of the Makefile where -R appears?
What about Makefile.in ?

-R is an obscure option to the lower-level compiler-only phase of
the compiler (i.e., ccom not cc).  If it appears it should always be
encapsulated in a -w option, such as

   -wc,-R   (no spaces)

I can't see how -R is needed, as it is a very low level optimzation
hint.  (If, in fact, the -R you see is intended to be the same as the
HP documented one).

In the mod_python I compiled I have no such -R option anyplace.
I can't explain why yours has it.  (Are you sure you're not confusing
it with the -R option to lex/flex?)

You could try just manually removing all references to -R from the
makefiles (after the configure step obviously).

> NEW MAKE RUN:  Removed silent as recommend but it must be hiding some
> where else...I tried to find it but to no avail.

The --silent option is burried very very deep; it's almost imposible
to remove.  When I need to see more details I don't use make,
I run the actual commands directly (run make first to see what
commands it is launching, then cut-n-paste the one you want and
modify the options directly).

However in this case I'm not sure we need to see the details,
as the -R in src/Makefile is obviously the source of the problem.

Deron Meranda

More information about the Mod_python mailing list