[mod_python] Mod_python on HP-UX 11.11

Buehre, Joseph R joseph.r.buehre at boeing.com
Wed Nov 15 12:11:22 EST 2006

Sorry for the slow response, but I will re-compile and send the errors
as I move along.
To answer the first questions, yes Apache was compiled with --enable-so
and I am doing a 32 bit compile.

Thanks in advance.!

Joe Buehre 
Mission Critical Systems Support 

 mailto:joseph.r.buehre at boeing.com

-----Original Message-----
From: Deron Meranda [mailto:deron.meranda at gmail.com] 
Sent: Thursday, November 02, 2006 4:12 PM
To: Buehre, Joseph R
Cc: mod_python at modpython.org
Subject: Re: [mod_python] Mod_python on HP-UX 11.11

I think you replied to the wrong thread...

On 11/2/06, Buehre, Joseph R <joseph.r.buehre at boeing.com> wrote:
> I have tried consently to get mod_python to compile and create the .so

> file for Apache.  To date this has been an unsucessful adventure.  Has

> anyone done this type of install with HP-UX 11.11, Apache 2.0 and the 
> latest version of mod_python.  Desperately seeking insight.

I did get it working (but not heavily tested) with these parts...

  HP-UX 11.0
  Apache 2.2 (mpm_worker, dso)
  OpenSSL 0.9.8d
  Python 2.4.3
  GNU readline 5.1
  mod_python 3.2.10

Everything (except the OS of course) was compiled from sources with HP's
ANSI-C cc compiler in 32-bit mode.

I've since got python 2.5 working now, but I haven't tried recompiling
the mod_python against it.

Did you also compile httpd?  If so did you make sure you used the
--enable-so option to configure?  Are you by chance trying to compile
64-bit applications?  Can you provide more information, such as what
kind of errors you might be seeing.  What configure options you've
given, etc.

I know getting stuff to compile under HP-UX can in general be a real
pain.  I may have done some sort of magic, but I honestly can't remember
what I did exactly.  At least it's not AIX; that one always gives me
terrible fits.
Deron Meranda

More information about the Mod_python mailing list