[mod_python] openbsd mod_python

Graham Dumpleton grahamd at dscpl.com.au
Mon Jan 23 23:39:48 EST 2006

Michael Steinfeld wrote ..
> On 1/23/06, Graham Dumpleton <grahamd at dscpl.com.au> wrote:
> > On 24/01/2006, at 3:24 AM, tony sarendal wrote:
> > >> It's also nice to hear from an OpenBSD user, but since that platform
> > >> is
> > >> heavily tweaked, it's useful to test installation on another platform
> > >> for comparison, to flag OpenBSD-specific issues.
> > > Regarding openbsd and mod_python, are there any specific issues
> > > anyone here has seen with that combo ?
> > >
> > > OpenBSD/apache2 required some tweaking with Semaphores to run ok,
> > > and I have so far avoided writing anything with Threading, as it gave
> > > me problems just runnning normal python stuff on openbsd.
> >
> > Which version of mod_python are you using? If using mod_python 3.1.4
> > or earlier, you really need to upgrade and try out 3.2.6. As it
> > addresses many issues across various platforms.
> >
> >    http://www.modpython.org/dist/
> first: OpenBSD uses httpd 1.3.6 so mod_python 3.2x wouldnt work
> second: i tried all other config possibilities ... including httpd
> 2.0x and mod_python 3.2 as well as the latest mod_python beta... all
> attempts returned the errors I posted abovel

Michael, that latest response of mine was in relation to issues posted
by Tony Sarendal not your original post.

In respect of your original problems, the last question I asked of you but which
was not answered, was for you to clarify which operating system you are really
using. Your subject line mentioned OpenBSD and you referred to OpenBSD
yet the version string information you posted at one point suggested you were
actually running Apple Mac OS X on a G5.

Thus, please indicate whether you are using a stock OpenBSD, Apple retail
version of Mac OS X or Open Source Darwin.

Anyway, so far from the mail trail the following seems to have transpired.

1. You tried using Apache 2.2 with mod_python 3.1.4. You were told to use
Apache 2.0 instead as 2.2 is not supported.

2. You then jumped in and posted that you were using G5 and gave version

  Python 2.4.1 (#1, Sep 4 2005, 01:46:49) [GCC 4.0.0 (Apple Computer,
  Inc. build 5026)]
  ('Darwin', 'g5', '8.4.0', 'Darwin Kernel Version 8.4.0: Tue Jan 3
  18:22:10 PST 2006; root:xnu-792.6.56.obj~1/RELEASE_PPC', 'Power

3. You then posted same problem as 1 but using Apache 2.0.

4. I asked for qualification on what platform you were using and if you were
using Mac OS X suggested one possible issue. See:


As yet you have not responded directly to query about platform, nor
indicated specifically whether the suggestion worked or didn't.

Without knowing eactly which platform you are using, cannot give
suggestions of what the issue may be or how to debug the problem.

BTW, please keep discussion on mod_python mailing list.


More information about the Mod_python mailing list