[mod_python] Mod_python 3.2.7 on RedHat Enterprise 3

Cassiano, Marco mcassiano at manord.com
Wed Feb 15 12:19:04 EST 2006

Thank you Jim,

It seems I have the correct version...

[root at oldsvi root]# apr-config --version



-----Original Message-----
From: Jim Gallacher [mailto:jpg at jgassociates.ca] 
Sent: Wednesday, February 15, 2006 6:15 PM
To: Cassiano, Marco
Cc: mod_python at modpython.org; martin at highwaytohell.net
Subject: Re: [mod_python] Mod_python 3.2.7 on RedHat Enterprise 3

Cassiano, Marco wrote:
>  Hi All,
> I tried to compile Mod_python 3.2.7 on RH3EL with ./configure --with-python=/usr/local/bin/python2.4 --with-apxs=/usr/sbin/apxs > config.log
> The compilation seems to be ok (some warnings) but when I start apache I get this error : 
> service httpd start
> Starting httpd: Syntax error on line 6 of /etc/httpd/conf.d/python.conf:
> Cannot load /etc/httpd/modules/mod_python.so into server: /etc/httpd/modules/mod_python.so: undefined symbol: apr_table_compress
> I tried to search the web with no result.
> Any help is appreciated

Most likely you have an older apr version. Mod_python 3.2.7 now uses 
apr_table_compress, which was added in APR 0.9.4. Could you confirm your 
version by running:

$ apr-config --version

Ref. http://www.apache.org/dist/apr/CHANGES-APR-0.9


More information about the Mod_python mailing list