[mod_python] mpcp

Barry Burns bburns at synset.net
Fri Aug 25 12:36:25 EDT 2006

Hello all,

I'm using (or attempting to use) mpcp to embed CherryPy apps with 
mod_python. I'm getting this message, however, when I try this:

Mod_python error: "PythonHandler mpcp"

Traceback (most recent call last):

  File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 287, in HandlerDispatch

  File "/usr/lib/python2.4/site-packages/mod_python/apache.py", line 454, in import_module
    f, p, d = imp.find_module(parts[i], path)

ImportError: No module named mpcp

When I launch a command-line interpreter, mpcp exists (it won't import 
because of missing _apache, but it finds mpcp). I tried Googling the 
error and it only returned another server with the same error... :)

I'm using Apache 2.0.55-r1, mod_python 3.1.4-r1, and mpcp-1.5 on a 
Gentoo system. Apache and mod_python were installed via Portage and mpcp 
was installed via EasyInstall, if any of that matters.


More information about the Mod_python mailing list