[mod_python] mod_python with Apache2.2?

Graham Dumpleton grahamd at dscpl.com.au
Sun Aug 13 08:24:58 EDT 2006

On 13/08/2006, at 10:19 PM, Ted wrote:

> Aha! Thank you very much! I hadn't chanced upon that particular  
> page, but it sure did wonders. In particular, I was missing  
> msvcp71.dll. Any reason why it's not packaged along with the rest  
> (purely out of curiousity)?
> In any case, thanks again :-) Now I can finally get something done.

I can't answer the question about msvc71.dll, but maybe others can. I  
have sent
your mail back onto the mailing list. It is always a good idea to  
keep your
responses on the mailing list as then other people know your problem has
been solved and they might also be able to assist with any followup  
you have. I actually know very little about Win32 platform so am  
definitely not
the person to be asking.


> Graham Dumpleton wrote:
>> Start by reading this prior post about Win32 setup issues in case  
>> there is
>> something in there which is relevant and helps.
>>   http://www.modpython.org/pipermail/mod_python/2006-June/021392.html
>> Graham
>> On 13/08/2006, at 8:45 PM, Ted wrote:
>>> Hi everyone,
>>> I've been trying to install mod_python with Apache 2.2 all night  
>>> with little success (actually, Apache 2.2.3 to be precise). First  
>>> of all, I'm wondering if it is even possible. I downloaded the  
>>> Windows version of v3.2.10 (mod_python-3.2.10.win32-py2.4- 
>>> apache2.2.exe), and I also have Python 2.4 installed (the latest  
>>> since I just downloaded it onto my laptop last night).
>>> Judging by the name, it should work. I ran the binary and  
>>> installed it. The files all seem to have appeared in my  
>>> mod_python folder somewhere inside c:\Python24 and mod_python.so  
>>> is in the modules folder inside my Apache2.2 folder as it should  
>>> be. I've added the statement: "LoadModule python_module modules/ 
>>> mod_python.so" but upon doing so, Apache will not restart (nor  
>>> start again).
>>> Once in awhile, the error log will show an error OS 995 having to  
>>> do with AcceptEx or something (I don't have the exact error  
>>> anymore), and when I Googled it, suggestions seemed to be to try  
>>> and add extra directives including Win32DisableAcceptEx. I did  
>>> this and it didn't seem to do anything, except now there aren't  
>>> any error messages at all, whether I take it out or put it in. If  
>>> I comment out the mod_python module, everything loads fine.
>>> Now, I had also rolled back to Apache 2.0.x as well and  
>>> downloaded mod_python 3.2.8 to try it out and the same situation  
>>> occurred.
>>> I probably should also point out that I have installed other  
>>> modules with success, such as PHP so I don't know why it won't  
>>> work with Python.
>>> Any help would be great, and gently if possible. I'm no good with  
>>> servers or the like. Thanks in advance for any help you guys can  
>>> give :-)
>>> Ted
>>> <http://www.uniontransit.com/apache/httpd/modpython/win/3.2.10/ 
>>> mod_python-3.2.10.win32-py2.4-apache2.2.exe>
>>> _______________________________________________
>>> Mod_python mailing list
>>> Mod_python at modpython.org
>>> http://mailman.modpython.org/mailman/listinfo/mod_python

More information about the Mod_python mailing list