[mod_python] PyThreadState_Delete: tstate is still current

Peter Sanchez petersanchez at gmail.com
Mon Oct 10 22:12:44 EDT 2005

Hey all...

I have an issue. I am developing some software for a website using
mod_python.publisher. I just upgraded from apache 1.3.33/mod_python
2.7.11 to apache2.0.54/mod_python3.1.4. They were installed via Ports,
and the OS is FreeBSD 4.11-STABLE.

The version of python installed is 2.4.1, no-threads. This was also
installed via ports.

Now, prior to the upgrade, the software I am working on, was
functioning correctly, now it is not. The entire data (html) is not
making it to the user (browser.) The page that is loading does load
most of the way, I can see images, text, etc. The entire page just
doesn't load, and my browser (Safari) reports a bad server response
(due to the mod_python script crashing, see below)

The logs show this:

Fatal Python error: PyThreadState_Delete: tstate is still current
[Mon Oct 10 18:49:48 2005] [notice] child pid 2161 exit signal Abort trap (6)

This is the same error for EVERY time I load any page (function) in my
python script. Like I said before, the code was working prior to the
upgrade. The reason for the upgrade is Session support, which appears
to only be in 3.x tree of mod_python.

This is the apache config I am using (in relation to mod_python):

<Directory /home/user/public_html/modpy>
        Options -MultiViews
        AddHandler python-program .py
        SetHandler python-program
        PythonHandler mod_python.publisher
        PythonDebug On
        Order allow,deny
        Allow from all

I have tried searching google and haven't found the solution. Can
anyone help me out here? Again, the script does give some data but
dies/crashes before it is complete.

Thanks in advance for any and all help!


More information about the Mod_python mailing list