[mod_python] Getting modpython and php to work on thesamecomputer

Jason Lanquist jason at ruff.com
Thu Mar 10 21:03:24 EST 2005

Thanks for the link, that's exactly my problem!  I tried it but ended up 
with bigger problems

I was unsure about what was the path to the mysql library so I thought 
it was the lib directory:
./configure --with-apxs2=/usr/local/apache/bin/apxs 
error: something to the effect of "this isn't the library"
./configure --with-apxs2=/usr/local/apache/bin/apxs 
same error
./configure --with-apxs2=/usr/local/apache/bin/apxs 
this one worked, but is this the mysql library?

anyway, I did a make/make install and then apache wouldn't start.  
something about not enough memory to create a lock

I deleted the "/usr/local/apache/", "/usr/local/httpd-2.0.49/", untarred 
the httpd-2.0.49.tar.gz and installed it , restarted the computer, 
started apache and now it works.
I installed mod_python again and now I have mod_python working correctly!

Now to install php...should I do a make clean before I configure it?
(here's what I'll type)
cd /usr/local/php-4.3.4
make clean
./configure --with-apxs2=/usr/local/apache/bin/apxs 
make install

Please correct me if I have the wrong path to the mysql library or 
confirm that it's correct. (/usr/local/mysql is the base directory where 
mysql is installed)

Thanks so much for all of your input on this!

Jason Lanquist

Graham Dumpleton wrote:

>Unless the URL got mangled, what I sent should have worked, it was just a
>more general query on anything PHP related, so picked up other stuff
>besides the MySQL issue as well. :-(
>More specific URL is good though as well. :-)
>Reed L. O'Brien wrote ..
>>I think Graham maybe meant this:
>>which basically says this:
>>The solution (from David Geller) is as follows:
>>In my httpd.conf I was loading two DSO modules: mod_python and php4. It
>>turns out, when I removed the reference to php4, the mod_python worked
>>perfectly. Now, why was this? Well, I went back to the php4 module, and
>>checked out "configure" - if you know anything about php, it was being
>>configured with the "--with-mysql" flag, which tells it to use an 
>>"internal" version of mysql libs. Apparently, this is fine - as long as
>>*no other modules use mysql* (the php configure tells you this at the 
>>end). If they do, you should specify the actual mysql library directory.
>>Well, mod_python was basically another module using mysql. Duuuuh! 
>>(well, not so obvious to me, really). When I specified the actual mysql
>>library to php configure, and recompiled and reinstalled the PHP, I 
>>could have LoadModules for both php and mod_python and both /appear/ to
>>Graham Dumpleton wrote:
>>>These problems usually come down to PHP and Python, or some module being
>>>used by either, being compiled against different versions of some shared
>>>library. The main culprit tends to be libexpat but there can also be
>>>issues with MySQL. See FAQ entry:
>>>   http://www.modpython.org/FAQ/faqw.py? 

More information about the Mod_python mailing list