[mod_python] Freebsd 5.3 - PyThreadState_Delete: tstate is still current

snacktime snacktime at gmail.com
Sat Jan 22 16:58:44 EST 2005

Freebsd 5.3-p2.  Python 2.4/mod_python 3.1.3 built from ports with
threading disabled (as per mod_python port requirement).

On some requests I get this error message:

Fatal Python error: PyThreadState_Delete: tstate is still current
[Sat Jan 22 21:47:12 2005] [notice] child pid 46205 exit signal Abort trap (6)

For example, with the following in httpd.conf:

<Directory /usr/local/www/data/python>
    SetHandler mod_python
  PythonHandler mod_python.publisher
  PythonDebug On

The example index.py from the docs works when the url is
/python/index.  But I get the error with /python/index/hello, or

The sample from section 3.3 of the docs does work.  When I tried using
a Location directive instead of Directory, I get the error.

Is something trying to use threads when it's not supposed to?  At
first I thought maybe I had built python with threads, but after
reinstalling python and mod_python without threads I still get the
same errors.

Any ideas?


More information about the Mod_python mailing list