[mod_python] Mod_python quit working

Dan R. Olsen III python at dan-olsen.net
Tue Jan 11 14:40:32 EST 2005

>>>>I had a mod_python file that I was working on a few days ago. Now, when 
>>>>I type in the URL nothing happens. The browser just stays on the page it 
>>>>was already on. I haven't made any changes to the file or the system.
>>>>I am using Fedora Core 2 with Apache 1.3 and mod_python 2.7. Any ideas?

>>>It seems to be broken! Have you tried fixing it in any way? Restarting
>>>apache? Echoing a simple string to the browser etc...

>>Yes, I've restarted Apache and I have echoed a simple string and niether 
>>of those have worked.

> Try getting the page with 'wget', see what headers you get back and if
> there is any content.

I get the following:

--12:38:00--  http://dev.eclab.byu.edu/rose.py
            => `rose.py'
Resolving dev.eclab.byu.edu...
Connecting to dev.eclab.byu.edu[]:80... connected.
HTTP request sent, awaiting response...
12:38:00 ERROR -1: No data received.

Why would it all of a sudden be receiving not data?

More information about the Mod_python mailing list