[mod_python] Build errors

Brandon Laing blaing at vancoservices.com
Wed Dec 14 16:09:56 EST 2005

Hey all,

I'm running into a problem trying to build Mod Python 3.1.4 on a Fedora 4 system. I'm building it because I need to to run Python 2.3, which has already been installed on the system and appears to be working properly.

So, I downloaded and extracted Mod Python 3.1.4, and ran "./configure --with-python=/usr/local/bin/python2.3" to build it against the correct version. Ok, it detects Python 2.3 and creates the make file. 

Next, I run make. After a minute, the make fails with this error:

/usr/bin/ld: /usr/local/lib/python2.3/config/libpython2.3.a(abstract.o): relocation R_X86_64_32S against `_Py_NotImplementedStruct' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/python2.3/config/libpython2.3.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
apxs:Error: Command failed with rc=65536
make[1]: *** [mod_python.so] Error 1
make[1]: Leaving directory `/root/mod_python-3.1.4/src'
make: *** [do_dso] Error 2

I've reinstalled Fedora twice now, just to be sure, and have been met with this same result both times. I have no idea where to go from here, or how to get this to build properly. 

Anyone seen this before, or know of a way to get around it?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mm_cfg_has_not_been_edited_to_set_host_domains/pipermail/mod_python/attachments/20051214/cda0c676/attachment.html

More information about the Mod_python mailing list