[mod_python] With OS X and Python 2.4 - installed but not working

Jason Stitt jason at pengale.com
Wed Dec 22 23:11:53 EST 2004

I am trying to get fresh source builds of Apache 2.0.52, Python 2.4 and 
Mod Python 3.1.3 -- that is, all the latest stable versions -- working 
on my Mac (OS X 10.3.7). I'm putting them in a separate directory 
~/server (so as not to mess around with the factory-default 
installations). It's not quite working.

Apache went in fine. I tried to install Python normally, but it refused 
to create a libpython for me (which mod_python said it needed), even 
with the --enable-shared configuration flag. So I made it a framework 
under ~/server/frameworks. In both cases, the python interpreter itself 
worked fine.

Then came mod_python. Once I did the framework install of python, it 
compiled OK. I gave it a --with-python flag pointing at the executable 
in my framework install. I have added the LoadModule to my config file, 
which looks like this:

LoadModule python_module 
<Directory /Users/jason/server/apache2/htdocs>
         AddHandler mod_python .py
         PythonHandler mod_python.publisher
         PythonDebug On

The server string reads:
Apache/2.0.52 (Unix) mod_python/3.1.3 Python/2.3 Server at localhost 
Port 8000

Note the odd inclusion of Python/2.3. I checked mod_python's makefile 
and it references only my shiny new python 2.4 directory.

Anyway, whenever I try to actually visit a python page, it either 
hangs/times out, or gives me a 500 internal server error. Nothing is 
written to the error_log.

Anyone experienced with this type of build on OS X? Any ideas?

Thanks much,

More information about the Mod_python mailing list