[mod_python] Follow up on install problems.

Matthew D. Wood woodm at colorado.edu
Mon Sep 16 21:40:01 EST 2002

Interesting.  Has anyone tried using mod-python in a threaded setting? 
I just wouldn't have thought that to be a problem.

So, just to be clear, if I recompile apache with threads support, will I
be able to create mod-python scripts that use threads?

On Mon, 2002-09-16 at 08:47, Gregory (Grisha) Trubetskoy wrote:
> To be more precise, it's an issues specifically on FreeBSD (and I guess on
> OpenBSD as well), which uses different libc's for threaded and not
> threaded apps. As a result, you can't mix the two, and Apache 1.3 is
> usually compiled against non-threaded libs since it doesn't care for
> threads. So your only options are to recompile Python without threads or
> compile Apache with threads (I've never tried the latter, but the former
> works just fine).
> The threaded/non-threaded thing doesn't seem to be an issue on Linux or
> Solaris.
> Grisha
> On Mon, 16 Sep 2002, Jack Diederich wrote:
> > > Every time I run either of those commands, my error_log file has the
> > > following appended:
> > >     /usr/libexec/ld.so: Undefined symbol "_pthread_mutex_init" called
> > >     from httpd:/usr/lib/apache/modules/mod_python.so at 0x402e0148
> > >
> > It looks like you either have python compiled with threads,
> > or a module that requires threads is being loaded.
> >
> > mod_python can't be compiled with threads due to the spawning nature of apache.
> >
> _______________________________________________
> Mod_python mailing list
> Mod_python at modpython.org
> http://www.modpython.org/mailman/listinfo/mod_python

More information about the Mod_python mailing list