[mod_python] mptest.py text does not interpret

Willem Fourie fourie_willem at hotmail.com
Fri Apr 5 15:12:27 EST 2002

Hi Reg

I've copied mptest and mptest.py (same content) to both webroot and 
webroot/python (the ScriptAlias dir). When I run the URL's I get:
1) http://server/mptest - displays text in browser
2) http://server/mptest.py - tries to download
3) http://server/python/mptest - displays text in browser
4) http://server/python/mptest.py - internal server error

It's the same with or without "AddType application/x-httpd-py .py"

Have a phat Phriday
Cheers then

----Original Message Follows----
From: Reg Charney <charney at charneyday.com>
To: Willem Fourie <fourie_willem at hotmail.com>
CC: mod_python at modpython.org
Subject: Re: [mod_python] mptest.py text does not interpret
Date: Thu, 04 Apr 2002 20:37:55 -0800

Could you please send a copy of the test program you are using. All my 
started with an invalid test program. My "fixes" kept on making things worse 
worse until I asked the list.


Willem Fourie wrote:

 > Hi Reg
 > Thanx very much for your reply, but unfortunately I had already removed 
 > AddType (tried with and without).
 > When the ScriptAlias directory points to the WebDir (and mptest.py placed 
 > that directory) then it shows the text sans interpretation.
 > With the config pointing to /python, and the file in that directory and 
 > URL pointing to /python/mptest.py the server responds with "The server
 > encountered an internal error or misconfiguration and was unable to 
 > your request"
 > Would appreciate ideas on other avenues perhaps.
 > Thanx

Chat with friends online, try MSN Messenger: http://messenger.msn.com

More information about the Mod_python mailing list