[mod_python] Dispatch() returned nothing (?)

Gary Perez garyp at asti-usa.com
Wed Jul 18 16:10:51 EST 2001

Hi, all.

Looking forward to getting this working... either that or it's back to
Zope! ;)

Here's the installation info:
SuSE Linux 7.2, kernel 2.4.4, reiserfs
Apache 1.3.19 + Python 2.0 + mod_python 2.7.2

(Note: I attempted to install mod_python 2.7.5 from source, and that
completely hosed Apache, so I went back to the YAST2-based 2.7.2 installation.)

I'm stuck at the "2.4 Testing" section; Apache is throwing an internal
server error on attempt to load http://localhost/test/mptest.py . Here
are pieces of the relevant files:

[Wed Jul 18 15:58:02 2001] [notice] Apache/1.3.19 (Unix)  (SuSE/Linux)
mod_layout/1.0 mod_throttle/3.0 mod_fastcgi/2.2.2 mod_ssl/2.8.3
OpenSSL/0.9.6a PHP/4.0.4pl1 mod_perl/1.25 mod_dtcl mod_python/2.7.2
Python/2.0 configured -- resuming normal operations
[Wed Jul 18 15:58:02 2001] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Jul 18 15:58:18 2001] [error] [client]
python_handler: Dispatch() returned nothing.

<Directory "/usr/local/httpd/htdocs/test">
    AddHandler python-program .py
    PythonHandler mptest
    PythonDebug On
    AllowOverride All

AddHandler python-program .py
PythonHandler mptest
PythonDebug On

I also tried it without the "AllowOverride" line in httpd.conf and no
.htaccess file in the directory, but it throws the same error.

Any ideas as to what I'm doing wrong? Thanks in advance for your help!

More information about the Mod_python mailing list