[mod_python] mod_python 3.3.1 make error

Graham Dumpleton grahamd at dscpl.com.au
Sat Mar 3 21:44:30 EST 2007

There are two issues in there.

On 03/03/2007, at 3:37 PM, Rares Vernica wrote:

> checking for flex... /opt/gnutools-1.1/bin/flex
> found /opt/gnutools-1.1/bin/flex, we'll use this. Use --with-flex  
> to specify another.
> checking flex version... awk: syntax error near line 1
> awk: bailing out near line 1
> awk: syntax error near line 1
> awk: bailing out near line 1
> awk: syntax error near line 1
> awk: bailing out near line 1
> ./configure: line 3187: test: : integer expression expected
> configure: WARNING: Flex version 2.5.4 found.
>     Version 2.5.31 or greater is required.  You can generally  
> ignore this
>     warning unless you need to regenerate psp_parser.c from  
> psp_parse.l.
>     If you do need regenerate psp_parser.c, use --with-flex to  
> specify the
>     location of the correct flex version. See the README for more  
> information.

Although this isn't stopping compilation, it is strange that awk is  

Which 'awk' is found first in your path. Ie., run:

   which awk

Looks like it may be finding the brain damaged BSD version of 'awk'  
than SYSV one. Do you have /usr/ucb in your PATH before normal /bin and

The mod_python configure script should really be doing a search for the
existence of 'gawk', 'nawk' and 'awk' in that order when it isn't.

> Compiling for DSO.
> /opt/apache-2.0.52/bin/apxs -I/home/rvernica/loquat/usr/apple/src/ 
> mod_python-3.3.1/src/include -I/opt/apache-2.0.52/include -I/opt/ 
> python/2.4.3/include/python2.4 -c mod_python.c _apachemodule.c  
> requestobject.c tableobject.c util.c serverobject.c connobject.c  
> filterobject.c hlist.c hlistobject.c finfoobject.c -L/opt/python/ 
> 2.4.3/lib/python2.4/config        -lm -lpython2.4   -lresolv - 
> lsocket -lnsl -lrt -ldl  -lpthread   -lm          _eprintf.o  
> _floatdidf.o _muldi3.o
> /opt/apache-2.0.52/build/libtool --silent --mode=compile gcc - 
> apache-2.0.52/include  -I/opt/apache-2.0.52/include -I/opt/ 
> apache-2.0.52/include -I/home/rvernica/loquat/usr/apple/src/ 
> mod_python-3.3.1/src/include -I/opt/apache-2.0.52/include -I/opt/ 
> python/2.4.3/include/python2.4  -c -o mod_python.lo mod_python.c &&  
> touch mod_python.slo
> In file included from /usr/include/sys/wait.h:24,
>                  from /opt/apache-2.0.52/include/apr.h:124,
>                  from /opt/apache-2.0.52/include/ap_config.h:19,
>                  from /opt/apache-2.0.52/include/httpd.h:29,
>                  from /home/rvernica/loquat/usr/apple/src/ 
> mod_python-3.3.1/src/include/mod_python.h:42,
>                  from mod_python.c:28:
> /usr/include/sys/siginfo.h:259: error: parse error before "ctid_t"
> /usr/include/sys/siginfo.h:292: error: parse error before '}' token
> /usr/include/sys/siginfo.h:294: error: parse error before '}' token
> /usr/include/sys/siginfo.h:390: error: parse error before "ctid_t"
> /usr/include/sys/siginfo.h:398: error: conflicting types for '__fault'
> /usr/include/sys/siginfo.h:267: error: previous declaration of  
> '__fault' was here

Can you post the 10 lines either side of line 259 in include file:


Looks like order of includes is causing a problem. But then the  
includes are
from Apache header files which should be okay.

Can you confirm that you are running older Solaris 8.

You might try dropping /usr/ucb from your path as well, but don't it  
will make a
difference to compilation problem.


More information about the Mod_python mailing list