[mod_python] compiling mod_python with httpd 2.2.2

Mika Borner Mika.Borner at clariden.com
Thu Jun 8 02:48:41 EDT 2006

Hello again...

I just tried this with httpd 2.2.0. The problem is the same. Is there a
library missing (in the path)? How can I find out?



>>> "Mika Borner" <Mika.Borner at clariden.com> 06/08/06 7:52 am >>>

I have problems compiling mod_python against httpd 2.2.2. I tried out
the newest version under trunk as well as the 3.2.x tree under

My system runs Solaris 10 (Sparc). 

/usr/include/sys/feature_tests.h:188:1: warning: this is the location
the previous definition
/u00/appl/apache2/apr-httpd/build-1/libtool --silent --mode=link gcc
mod_python.la  -rpath /u00/appl/apache2/modules -module -avoid-version 

 hlistobject.lo hlist.lo filterobject.lo connobject.lo serverobject.lo
util.lo tableobject.lo requestobject.lo _apachemodule.lo mod_python.lo
-L/u00/appl/python/lib/python2.4/config -lm -lpython2.4 -lresolv
-lsocket -lnsl -lrt -ldl -lm _eprintf.o _floatdidf.o _muldi3.o

*** Warning: Linking the shared library mod_python.la against the
*** objects  _eprintf.o _floatdidf.o _muldi3.o is not portable!
Text relocation remains                         referenced
    against symbol                  offset      in file
<unknown>                           0x0        
<unknown>                           0x4        
<unknown>                           0x8        
Very Long List (ommitted)
ld: fatal: relocations remain against allocatable but non-writable
collect2: ld returned 1 exit status
apxs:Error: Command failed with rc=65536

httpd was compiled with options:

./configure --prefix=/u00/appl/apache2 \
--enable-mods-shared=all \
--libdir=/usr/local/lib \
--with-apr=/u00/appl/apache2/apr-httpd \
--with-apr-util=/u00/appl/apache2/apr-util-httpd \

mod_python was compiled with options:

./configure --with-apxs=/u00/appl/apache2/bin/apxs

During configure also this error is raised (might be a non issue):  

checking for --with-flex... /usr/local/bin/flex
found /usr/local/bin/flex, we'll use this. Use --with-flex to specify
checking flex version... awk: syntax error near line 1
awk: bailing out near line 1
awk: syntax error near line 1
awk: bailing out near line 1
awk: syntax error near line 1
awk: bailing out near line 1
./configure: line 3187: test: : integer expression expected
configure: WARNING: Flex version 2.5.31 found.
    Version 2.5.31 or greater is required.  You can generally ignore
    warning unless you need to regenerate psp_parser.c from
    If you do need regenerate psp_parser.c, use --with-flex to specify
    location of the correct flex version. See the README for more

Any ideas?

This message is intended for the addressee only and may
contain confidential or privileged information. If you
are not the intended receiver, any disclosure, copying
to any person or any action taken or omitted to be taken
in reliance on this e-mail, is prohibited and may be un-
lawful. You must therefore delete this e-mail.
Internet communications may not be secure or error-free
and may contain viruses. They may be subject to possible
data corruption, accidental or on purpose. This e-mail is
not and should not be construed as an offer or the
solicitation of an offer to purchase or subscribe or sell
or redeem any investments.

Mod_python mailing list
Mod_python at modpython.org

More information about the Mod_python mailing list